Apache Struts 2.3.34 发布,修复安全问题

Apache Struts 2.3.34 已发布,该版本修复了以下潜在的安全漏洞:

  • S2-050 当使用 URLValidator 时,可能会导致 DoS 攻击 (与 S2-044 & S2-047 类似)

  • S2-051 远程攻击者可能会在使用 Struts REST 插件时发送精心设计的 xml 请求来创建DoS攻击

  • S2-052 当使用带有 XStream 处理程序的 Struts REST 插件来处理 XML 有效负载时,可能会发生远程执行代码攻击

  • S2-053 在 Freemarker tag 中使用无意图的表达式而不是字符串文字时,可能会发生远程执行代码攻击

以及几个小的改进:

  • Struts2 JSON 插件:以带有字符串的 Map 作为 Key 发送到 JSON Action 被忽略,Numeric Keys 可工作和映射

  • 由于 OgnlRuntime Dependency 中的不必要的同步,线程被阻塞

  • 升级至 OGNL 3.0.21

  • 升级至 struts-master 11

  • 改进用于验证 URL 的 RegEx

详细发布说明点此参阅

下载地址

Struts 是 Apache软件基金会(ASF)赞助的一个开源项目。它最初是 Jakarta项目中的一个子项目,并在2004年3月成为ASF的顶级项目。它通过采用 Java Servlet/JSP 技术,实现了基于Java EE Web应用的MVC设计模式的应用框架,是MVC经典设计模式中的一个经典产品。

Original article: 

Apache Struts 2.3.34 发布,修复安全问题