Gradle 4.3.1 发布,项目自动化构建工具

Gradle 4.3.1 已发布,Gradle 就是可以使用 Groovy 来书写构建脚本的构建系统,支持依赖管理和多项目,类似 Maven,但比之简单轻便。

这个 bug 修复版本解决了 Gradle 4.3 中的 3 个回归错误。

  • Gradle 4.3 引入了一个更改,其中从一个存储库解析模块出错时,会阻止Gradle在随后的存储库中搜索相同的模块。但是在4.3.1中,只有存储库超时时才会阻止Gradle在后续的存储库中搜索模块。

  • 此外,HTTP / HTTPS 请求的连接和套接字超时已增加到30秒。

  • --scan构建扫描插件应在其他插件之前使用,以避免呈现警告消息。

有关已解决问题的完整列表,请参阅GitHub milestone

升级说明

通过更新包装器属性来切换你的版本来使用Gradle 4.3.1:

./gradlew wrapper --gradle-version=4.3.1

独立下载位于:https://gradle.org/install

下载地址:

Continue reading here – 

Gradle 4.3.1 发布,项目自动化构建工具