Apache Log4j 2.10.0 正式发布,包含大量更新

Apache Log4j 2.10.0 正式发布了,此版本包含新功能引入、错误修正和次要的功能增强。其中一些新功能包括对 Java 9 模块系统的支持、对新的 SLF4j 1.8 绑定机制的支持,简化 Log4j 属性命名方案以及原生支持 Jetty 的记录器。

Log4j API 现在是一个完全兼容的 Java 9 模块,而其他 Log4j jar 包是 Java 9 命名的自动模块。

该版本支持 SLF4J 1.7.x 和 SLF4J 1.8.x。由于 SLF4J 1.7.x 要求实现包含 org.slf4j.impl 包中的类,因此 log4j-sl4j-impl 不能用作 Java 9 模块。在未来的版本中,对 SLF4J 1.7.x 的支持将被移除。

从 Log4j 2.9.0 开始,Log4j API 被修改为使用 java.util.ServiceLoader 来确定 Log4j 的实现,此前的绑定机制仍然受支持。Log4j API jar 包现在是一个多版本的 jar 包,用来提供 Java 9 特定类的实现。

OSGi 规范不支持多版本的 jar 包,所以 OSGi 模块将无法利用这些实现。请注意,有些工具与多版本 jar 包不兼容,可能无法处理 META-INF/versions/9 文件夹中的类文件,这些错误可向工具提供者反馈。

Apache Log4j 2.10.0 的运行环境要求最低是 Java 7,Log4j 2.3 是最后一个支持 Java 6 的版本。

更新内容较多,详情可查看发布主页更新日志

下载地址:https://logging.apache.org/log4j/2.x/download.html

See more here: 

Apache Log4j 2.10.0 正式发布,包含大量更新