Skywalking APM 3.2.6 发布,修复了大量的兼容性问题

SkyWalking 3.2.6 在12月6日完成版本发布,修复了大量的兼容性问题,和增加了新的调试手段。同时,这将是SkyWalking的最后一个3.x线路上的功能性发布版本。

至此,SkyWalking完成了其核心技术的多项验证,包括:功能性、探针性能优化、探针插件化、多版本程序支持、Collector模块化,多存储模块切换等等。经过SkyWalking PMC团队确认,我们将进行一次大型版本迭代,预计在明年2月份,发布5.0-2018-preview。具体内容,尽情期待,我们会随着进度陆续放出。

3.2.6更新如下:

Features

  • 当 agent.is_open_debugging_class = true时,探针会讲修改后的文件,保存到debugging目录下,方便应用(PMC)

  • 升级 gRPC 1.8 和 netty 4.1.17 (PMC)

  • 支持 Elastic-Job 插件. (@hanahmily)

Bugs

  • Collector log4j 配置文件错误. (PMC)

  • Spring 3.0 and 3.1 插件兼容性问题. (PMC)

  • Postgre SQL 插件兼容性问题. (PMC)

  • MySQL 5.0 插件兼容性问题. (PMC)

  • Spring 内核兼容性问题. (PMC)

  • Oracle 插件针对使用TNSName兼容性问题. (PMC)

  • Collector 在不同JVM下,运行集群模式问题. (PMC)

View original article:  

Skywalking APM 3.2.6 发布,修复了大量的兼容性问题